[PATCH yams] [pkg] require python >= 3.6

Philippe Pepiot philippe.pepiot at logilab.fr
Tue Mar 10 09:07:25 CET 2020


# HG changeset patch
# User Philippe Pepiot <philippe.pepiot at logilab.fr>
# Date 1583827562 -3600
#      Tue Mar 10 09:06:02 2020 +0100
# Node ID 4f4082af81e782214fffdaf93d37ff43dc29adb7
# Parent  deb24bc5407f8463ae2996e9bb7824d01ed74edd
# Available At https://hg.logilab.org/review/yams
#              hg pull https://hg.logilab.org/review/yams -r 4f4082af81e7
[pkg] require python >= 3.6

Some recently added types syntax is only available since python 3.6

diff --git a/debian/control b/debian/control
--- a/debian/control
+++ b/debian/control
@@ -17,7 +17,7 @@ Homepage: http://www.logilab.org/project
 Vcs-Hg: https://hg.logilab.org/master/yams
 Vcs-Browser: https://hg.logilab.org/master/yams
 Standards-Version: 4.3.0
-X-Python3-Version: >= 3.4
+X-Python3-Version: >= 3.6
 
 Package: python3-yams
 Architecture: all
diff --git a/setup.py b/setup.py
--- a/setup.py
+++ b/setup.py
@@ -53,7 +53,7 @@ setup(
     url=pkginfo['web'],
     classifiers=pkginfo.get('classifiers', []),
     packages=find_packages(exclude=['test*']),
-    python_requires='>=3',
+    python_requires='>=3.6',
     install_requires=pkginfo.get('install_requires'),
     scripts=pkginfo.get('scripts', []),
     ext_modules=pkginfo.get('ext_modules'),




More information about the cubicweb-devel mailing list