[PATCH 2 of 5 file] [debian] depend on python-all

Philippe Pepiot philippe.pepiot at logilab.fr
Thu Jun 27 18:14:23 CEST 2019


# HG changeset patch
# User Philippe Pepiot <philippe.pepiot at logilab.fr>
# Date 1561649375 -7200
#      Thu Jun 27 17:29:35 2019 +0200
# Node ID 9c5da38c343439bfb6a4054159eba8dd6161d345
# Parent  5f2e5ddf852db31db1141e83d731213e9f9d9d72
# Available At https://hg.logilab.org/review/cubes/file
#              hg pull https://hg.logilab.org/review/cubes/file -r 9c5da38c3434
[debian] depend on python-all

I'm not sure why it's better, but it looks to be the current standard.

diff --git a/debian/control b/debian/control
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Uploaders:
   David Douard <david.douard at logilab.fr>,
 Build-Depends:
  debhelper (>= 9),
- python (>= 2.7),
+ python-all (>= 2.7),
  dh-python,
  python-setuptools,
 Standards-Version: 3.9.8



More information about the cubicweb-devel mailing list