[PATCH 6 of 9 postgis] [debian] Let dh-python generate dependencies from requires.txt

Philippe Pepiot philippe.pepiot at logilab.fr
Thu Jun 27 16:56:44 CEST 2019


# HG changeset patch
# User Philippe Pepiot <philippe.pepiot at logilab.fr>
# Date 1561645258 -7200
#      Thu Jun 27 16:20:58 2019 +0200
# Node ID ab1fd5f61a340618be71885ff5ad8400fbaa3e41
# Parent  089435394967028eeec332344eb82072fcf1f4b3
# Available At https://hg.logilab.org/review/cubes/postgis
#              hg pull https://hg.logilab.org/review/cubes/postgis -r ab1fd5f61a34
[debian] Let dh-python generate dependencies from requires.txt

We add a pydist-overrides to handle cubicweb, as it's not available in official Debian repositories.

diff --git a/debian/control b/debian/control
--- a/debian/control
+++ b/debian/control
@@ -14,7 +14,6 @@ X-Python-Version: >= 2.7
 Package: cubicweb-postgis
 Architecture: all
 Depends:
- python-cubicweb (>= 3.24.0),
  ${python:Depends},
  ${misc:Depends},
 Description: Cube for GIS data support using PostGIS
diff --git a/debian/pydist-overrides b/debian/pydist-overrides
new file mode 100644
--- /dev/null
+++ b/debian/pydist-overrides
@@ -0,0 +1,1 @@
+cubicweb python-cubicweb



More information about the cubicweb-devel mailing list