[PATCH 5 of 7 forgotpwd] [debian] Let dh-python generate dependencies from requires.txt

Denis Laxalde denis.laxalde at logilab.fr
Wed Jun 26 11:00:17 CEST 2019


Noé Gaumont a écrit :
> I think you meant cubicweb_forgotpwd/__pkginfo__.py as there is no
> requires.txt but I don't know pydist-overrides.

No, I meant requires.txt :)
This is a file generated by python packaging tools (usually in
<project>.egg-info directory); it contains install requirements read
from setup.py (which sources __pkginfo__.py in our case).

dh-python (debian helper for python packages) uses this to translate
python packages name into debian packages name. This is explained in
dh_python3 manpage (see the "dependencies" section):

  https://manpages.debian.org/stretch/dh-python/dh_python3.1.en.html



More information about the cubicweb-devel mailing list