[PATCH 09 of 11 cubicweb/debian] [pkg] Use “dependency package” instead of “virtual package” to describe python3-cubicweb-postgresql-support

Jérémy Bobbio jeremy.bobbio at irq7.fr
Thu Jun 13 17:19:03 CEST 2019


# HG changeset patch
# User Jérémy Bobbio <jeremy.bobbio at irq7.fr>
# Date 1560158724 -7200
#      Mon Jun 10 11:25:24 2019 +0200
# Node ID fad67e7be85168e3122b9dd2838ef39e5728a9c5
# Parent  ca68d95a1692eb173abe61d21c7d4bf0f16427b3
[pkg] Use “dependency package” instead of “virtual package” to describe python3-cubicweb-postgresql-support

The term “virtual” was too imprecise and is not accepted for empty
packages by Lintian anymore.

diff -r ca68d95a1692 -r fad67e7be851 debian/changelog
--- a/debian/changelog	Mon Jun 10 11:15:17 2019 +0200
+++ b/debian/changelog	Mon Jun 10 11:25:24 2019 +0200
@@ -9,6 +9,8 @@
   * Stop using an empty (and obsolete) /etc/bash_completion.d with
     cubicweb-ctl.
   * Move lintian-overrides file to debian/source directory.
+  * Use “dependency package” instead of “virtual package” to describe
+    python3-cubicweb-postgresql-support.
 
  -- Jérémy Bobbio <jeremy.bobbio at irq7.fr>  Wed, 29 May 2019 16:06:20 +0200
 
diff -r ca68d95a1692 -r fad67e7be851 debian/control
--- a/debian/control	Mon Jun 10 11:15:17 2019 +0200
+++ b/debian/control	Mon Jun 10 11:25:24 2019 +0200
@@ -130,7 +130,7 @@
 Description: postgres support for the CubicWeb framework
  CubicWeb is a semantic web application framework.
  .
- This virtual package provides dependencies to use PostgreSQL for the
+ This dependency package provides dependencies to use PostgreSQL for the
  cubicweb repository.
 
 


More information about the cubicweb-devel mailing list