[PATCH 04 of 11 cubicweb/debian] [pkg] Remove build dependency on dh-systemd

Jérémy Bobbio jeremy.bobbio at irq7.fr
Thu Jun 13 17:18:58 CEST 2019


# HG changeset patch
# User Jérémy Bobbio <jeremy.bobbio at irq7.fr>
# Date 1560156691 -7200
#      Mon Jun 10 10:51:31 2019 +0200
# Node ID 4b27f2edb364b92fce854442b8077f45a06a4d94
# Parent  0212118394c1beb5c44b45fe8728f0175406d3a3
[pkg] Remove build dependency on dh-systemd

As suggested by Lintian, remove build dependency on obsolete package
dh-systemd. Instead, specify a more precise version of debhelper 9 that
added support for systemd.

diff -r 0212118394c1 -r 4b27f2edb364 debian/changelog
--- a/debian/changelog	Wed Jun 05 18:35:51 2019 +0200
+++ b/debian/changelog	Mon Jun 10 10:51:31 2019 +0200
@@ -3,6 +3,7 @@
   * Switch all Debian packages to Python 3.
   * Switch to Debian source format 3.0 (quilt).
   * Run test suite as part of autopkgtest.
+  * Remove build dependency on obsolete dh-systemd.
 
  -- Jérémy Bobbio <jeremy.bobbio at irq7.fr>  Wed, 29 May 2019 16:06:20 +0200
 
diff -r 0212118394c1 -r 4b27f2edb364 debian/control
--- a/debian/control	Wed Jun 05 18:35:51 2019 +0200
+++ b/debian/control	Mon Jun 10 10:51:31 2019 +0200
@@ -5,9 +5,8 @@
 Uploaders: Sylvain Thenault <sylvain.thenault at logilab.fr>,
            David Douard <david.douard at logilab.fr>,
 Build-Depends:
- debhelper (>= 9),
+ debhelper (>= 9.20160709),
  dh-python,
- dh-systemd,
  python3-all,
  python3-setuptools,
  python3-six (>= 1.4.0),


More information about the cubicweb-devel mailing list