[PATCH 01 of 11 cubicweb/debian] [pkg] Switch all Debian packages to Python 3

Jérémy Bobbio jeremy.bobbio at irq7.fr
Thu Jun 13 17:18:55 CEST 2019


# HG changeset patch
# User Jérémy Bobbio <jeremy.bobbio at irq7.fr>
# Date 1559741909 -7200
#      Wed Jun 05 15:38:29 2019 +0200
# Node ID dc093676eb20d6c52c1438ffb1521661c5dc727e
# Parent  de1c0721656e72bfc4fdcf3c1a3ab40895801d2e
[pkg] Switch all Debian packages to Python 3

diff -r de1c0721656e -r dc093676eb20 debian/changelog
--- a/debian/changelog	Tue Jun 11 09:40:12 2019 +0200
+++ b/debian/changelog	Wed Jun 05 15:38:29 2019 +0200
@@ -1,3 +1,9 @@
+cubicweb (3.27.0~dev0-1) UNRELEASED; urgency=medium
+
+  * Switch all Debian packages to Python 3.
+
+ -- Jérémy Bobbio <jeremy.bobbio at irq7.fr>  Wed, 29 May 2019 16:06:20 +0200
+
 cubicweb (3.26.11-1) unstable; urgency=medium
 
   * New upstream release.
diff -r de1c0721656e -r dc093676eb20 debian/control
--- a/debian/control	Tue Jun 11 09:40:12 2019 +0200
+++ b/debian/control	Wed Jun 05 15:38:29 2019 +0200
@@ -8,72 +8,72 @@
  debhelper (>= 9),
  dh-python,
  dh-systemd,
- python-all,
- python-setuptools,
- python-six (>= 1.4.0),
- python-docutils,
- python-sphinx,
- python-logilab-common (>= 1.4.0),
- python-logilab-mtconverter,
- python-markdown,
- python-tz,
- python-rql (>= 0.34.0),
- python-yams (>= 0.45.0),
- python-lxml,
- python-setuptools,
- python-pyramid,
- python-pyramid-multiauth,
- python-waitress,
- python-passlib,
- python-repoze.lru,
- python-wsgicors,
- python-filelock,
+ python3-all,
+ python3-setuptools,
+ python3-six (>= 1.4.0),
+ python3-docutils,
+ python3-sphinx,
+ python3-logilab-common (>= 1.4.0),
+ python3-logilab-mtconverter,
+ python3-markdown,
+ python3-tz,
+ python3-rql (>= 0.34.0),
+ python3-yams (>= 0.45.0),
+ python3-lxml,
+ python3-setuptools,
+ python3-pyramid,
+ python3-pyramid-multiauth,
+ python3-waitress,
+ python3-passlib,
+ python3-repoze.lru,
+ python3-wsgicors,
+ python3-filelock,
  sphinx-common,
-Standards-Version: 3.9.6
+Standards-Version: 4.3.0
 Homepage: https://www.cubicweb.org
-X-Python-Version: >= 2.7
+X-Python3-Version: >= 3.4
 
 
-Package: python-cubicweb
+Package: python3-cubicweb
 Architecture: all
 Depends:
  ${misc:Depends},
- ${python:Depends},
- python-six (>= 1.4.0),
- python-logilab-mtconverter (>= 0.8.0),
- python-logilab-common (>= 1.4.0),
- python-logilab-database (>= 1.15.0),
- python-yams (>= 0.45.0),
- python-rql (>= 0.34.0),
- python-lxml,
- python-markdown,
- python-passlib,
- python-tz,
+ ${python3:Depends},
+ python3-six (>= 1.4.0),
+ python3-logilab-mtconverter (>= 0.8.0),
+ python3-logilab-common (>= 1.4.0),
+ python3-logilab-database (>= 1.15.0),
+ python3-yams (>= 0.45.0),
+ python3-rql (>= 0.34.0),
+ python3-lxml,
+ python3-markdown,
+ python3-passlib,
+ python3-tz,
  graphviz,
- python-filelock,
+ python3-filelock,
  gettext,
 Recommends:
  cubicweb-ctl (= ${source:Version}),
- python-cubicweb-postgresql-support (= ${source:Version})
+ python3-cubicweb-postgresql-support (= ${source:Version})
  | sqlite3,
- python-cubicweb-pyramid (= ${source:Version}),
+ python3-cubicweb-pyramid (= ${source:Version}),
 # common recommends
- python-simpletal (>= 4.0),
- python-pycryptodome,
+ python3-simpletal (>= 4.0),
+ python3-pycryptodome,
 # web recommends (mostly)
- python-docutils (>= 0.6),
- python-vobject,
+ python3-docutils (>= 0.6),
+ python3-vobject,
  fckeditor,
- python-fyzz,
- python-imaging,
- python-rdflib,
- python-werkzeug,
+ python3-fyzz,
+ python3-imaging,
+ python3-rdflib,
+ python3-werkzeug,
 # dev recommends
- python-pysqlite2,
+ python3-pysqlite2,
 Suggests:
- python-zmq,
- python-cwclientlib (>= 0.4.0),
- python-cubicweb-documentation (= ${source:Version}),
+ python3-zmq,
+ python3-cwclientlib (>= 0.4.0),
+ python3-cubicweb-documentation (= ${source:Version}),
  w3c-dtd-xhtml,
  xvfb,
 Replaces:
@@ -117,7 +117,7 @@
  packages on the different hosts.
 
 
-Package: python-cubicweb-postgresql-support
+Package: python3-cubicweb-postgresql-support
 Architecture: all
 # postgresql-client packages for backup/restore of non local database
 Replaces: cubicweb-postgresql-support (<< 3.24.0-1~)
@@ -125,8 +125,8 @@
 Provides: cubicweb-postgresql-support
 Depends:
  ${misc:Depends},
- ${python:Depends},
- python-psycopg2,
+ ${python3:Depends},
+ python3-psycopg2,
  postgresql-client
 Description: postgres support for the CubicWeb framework
  CubicWeb is a semantic web application framework.
@@ -135,17 +135,17 @@
  cubicweb repository.
 
 
-Package: python-cubicweb-pyramid
+Package: python3-cubicweb-pyramid
 Architecture: all
 Depends:
- python-cubicweb (= ${source:Version}),
- python-pyramid (>= 1.5.0),
- python-pyramid-multiauth,
- python-waitress (>= 0.8.9),
- python-wsgicors,
- python-repoze.lru,
+ python3-cubicweb (= ${source:Version}),
+ python3-pyramid (>= 1.5.0),
+ python3-pyramid-multiauth,
+ python3-waitress (>= 0.8.9),
+ python3-wsgicors,
+ python3-repoze.lru,
 Recommends:
- python-pyramid-debugtoolbar
+ python3-pyramid-debugtoolbar
 Conflicts:
  pyramid-cubicweb
 Replaces:
@@ -159,8 +159,8 @@
 Architecture: all
 Depends:
  ${misc:Depends},
- ${python:Depends},
- python-cubicweb (= ${source:Version})
+ ${python3:Depends},
+ python3-cubicweb (= ${source:Version})
 Description: tool to manage the CubicWeb framework
  CubicWeb is a semantic web application framework.
  .
@@ -169,7 +169,7 @@
  to automatically start and stop CubicWeb applications on boot or shutdown.
 
 
-Package: python-cubicweb-documentation
+Package: python3-cubicweb-documentation
 Architecture: all
 Section: doc
 Replaces: cubicweb-documentation (<< 3.24.0-1~)
@@ -193,7 +193,7 @@
 Priority: extra
 Section: oldlibs
 Depends:
- python-cubicweb, ${misc:Depends}
+ python3-cubicweb, ${misc:Depends}
 Description: transitional package
   This is a transitional package. It can safely be removed.
 
@@ -203,7 +203,7 @@
 Priority: extra
 Section: oldlibs
 Depends:
- python-cubicweb, ${misc:Depends}
+ python3-cubicweb, ${misc:Depends}
 Description: transitional package
   This is a transitional package. It can safely be removed.
 
@@ -213,7 +213,7 @@
 Priority: extra
 Section: oldlibs
 Depends:
- python-cubicweb-postgresql-support, ${misc:Depends}
+ python3-cubicweb-postgresql-support, ${misc:Depends}
 Description: transitional package
   This is a transitional package. It can safely be removed.
 
@@ -223,7 +223,7 @@
 Priority: extra
 Section: oldlibs
 Depends:
- python-cubicweb, ${misc:Depends}
+ python3-cubicweb, ${misc:Depends}
 Description: transitional package
   This is a transitional package. It can safely be removed.
 
@@ -233,7 +233,7 @@
 Priority: extra
 Section: oldlibs
 Depends:
- python-cubicweb, ${misc:Depends}
+ python3-cubicweb, ${misc:Depends}
 Description: transitional package
   This is a transitional package. It can safely be removed.
 
@@ -243,7 +243,7 @@
 Priority: extra
 Section: oldlibs
 Depends:
- python-cubicweb, ${misc:Depends}
+ python3-cubicweb, ${misc:Depends}
 Description: transitional package
   This is a transitional package. It can safely be removed.
 
@@ -253,6 +253,6 @@
 Priority: extra
 Section: oldlibs
 Depends:
- python-cubicweb-documentation, ${misc:Depends}
+ python3-cubicweb-documentation, ${misc:Depends}
 Description: transitional package
   This is a transitional package. It can safely be removed.
diff -r de1c0721656e -r dc093676eb20 debian/python-cubicweb-documentation.doc-base
--- a/debian/python-cubicweb-documentation.doc-base	Tue Jun 11 09:40:12 2019 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,9 +0,0 @@
-Document: cubicweb-doc
-Title: CubicWeb Documentation
-Author: Logilab
-Abstract: Some base documentation for CubicWeb users and developpers
-Section: Apps/Programming
-
-Format: HTML
-Index: /usr/share/doc/python-cubicweb-documentation/html/index.html
-Files: /usr/share/doc/python-cubicweb-documentation/html/*
diff -r de1c0721656e -r dc093676eb20 debian/python-cubicweb-documentation.docs
--- a/debian/python-cubicweb-documentation.docs	Tue Jun 11 09:40:12 2019 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,2 +0,0 @@
-debian/cubicweb-doc/html 
-doc/book
diff -r de1c0721656e -r dc093676eb20 debian/python-cubicweb.lintian-overrides
--- a/debian/python-cubicweb.lintian-overrides	Tue Jun 11 09:40:12 2019 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,2 +0,0 @@
-missing-dep-for-interpreter make => make | build-essential | dpkg-dev (usr/*/cubicweb/skeleton/debian/rules)
-embedded-javascript-library usr/share/cubicweb/cubes/shared/data/jquery.js
diff -r de1c0721656e -r dc093676eb20 debian/python3-cubicweb-documentation.doc-base
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/debian/python3-cubicweb-documentation.doc-base	Wed Jun 05 15:38:29 2019 +0200
@@ -0,0 +1,9 @@
+Document: cubicweb-doc
+Title: CubicWeb Documentation
+Author: Logilab
+Abstract: Some base documentation for CubicWeb users and developpers
+Section: Apps/Programming
+
+Format: HTML
+Index: /usr/share/doc/python3-cubicweb-documentation/html/index.html
+Files: /usr/share/doc/python3-cubicweb-documentation/html/*
diff -r de1c0721656e -r dc093676eb20 debian/python3-cubicweb-documentation.docs
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/debian/python3-cubicweb-documentation.docs	Wed Jun 05 15:38:29 2019 +0200
@@ -0,0 +1,2 @@
+debian/cubicweb-doc/html 
+doc/book
diff -r de1c0721656e -r dc093676eb20 debian/python3-cubicweb.lintian-overrides
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/debian/python3-cubicweb.lintian-overrides	Wed Jun 05 15:38:29 2019 +0200
@@ -0,0 +1,2 @@
+missing-dep-for-interpreter make => make | build-essential | dpkg-dev (usr/*/cubicweb/skeleton/debian/rules)
+embedded-javascript-library usr/share/cubicweb/cubes/shared/data/jquery.js
diff -r de1c0721656e -r dc093676eb20 debian/rules
--- a/debian/rules	Tue Jun 11 09:40:12 2019 +0200
+++ b/debian/rules	Wed Jun 05 15:38:29 2019 +0200
@@ -6,11 +6,10 @@
 # export DH_VERBOSE=1
 
 export PYBUILD_NAME=cubicweb
-export PYBUILD_DISABLE_python2=test
 export PYBUILD_DISABLE_python3=test
 
 %:
-	dh $@ --with python2,sphinxdoc --buildsystem=pybuild
+	dh $@ --with python3,sphinxdoc --buildsystem=pybuild
 
 override_dh_auto_build: export http_proxy=127.0.0.1:9
 override_dh_auto_build: export https_proxy=127.0.0.1:9


More information about the cubicweb-devel mailing list