[PATCH 1 of 7 cubicweb/debian] [pkg] Remove explicit Depends on Python packages for python3-cubicweb

Jérémy Bobbio jeremy.bobbio at irq7.fr
Wed Jun 19 19:15:38 CEST 2019


# HG changeset patch
# User Jérémy Bobbio <jeremy.bobbio at irq7.fr>
# Date 1560760652 -7200
#      Mon Jun 17 10:37:32 2019 +0200
# Node ID b40e22937e14579b49c320e1bdc6ee878af1b7a7
# Parent  33b489b4593791cd1309e6263251db276a8300ce
[pkg] Remove explicit Depends on Python packages for python3-cubicweb

As suggested by Denis Laxalde, we can let pybuild generate the list
of Depends from the egg requirements.

The list we get is slightly less specific in terms of needed versions,
but given the age of the previous ones, it's unlikely to cause issues.
Also we lose python3-six from the list… which is correct as it was
removed from the dependencies in 26744ad37953.

diff -r 33b489b45937 -r b40e22937e14 debian/control
--- a/debian/control	Mon Jun 10 12:04:39 2019 +0200
+++ b/debian/control	Mon Jun 17 10:37:32 2019 +0200
@@ -38,18 +38,7 @@
 Depends:
  ${misc:Depends},
  ${python3:Depends},
- python3-six (>= 1.4.0),
- python3-logilab-mtconverter (>= 0.8.0),
- python3-logilab-common (>= 1.4.0),
- python3-logilab-database (>= 1.15.0),
- python3-yams (>= 0.45.0),
- python3-rql (>= 0.34.0),
- python3-lxml,
- python3-markdown,
- python3-passlib,
- python3-tz,
  graphviz,
- python3-filelock,
  gettext,
 Recommends:
  cubicweb-ctl (= ${source:Version}),


More information about the cubicweb-devel mailing list