[Python-projects] [rql] [PATCH] Update Debian packaging

Denis Laxalde denis.laxalde at logilab.fr
Tue Jun 4 15:22:18 CEST 2019


Hi Jérémy, and welcome,

JXXrXXmy Bobbio a écrit :
> # HG changeset patch
> # User Jérémy Bobbio <jeremy.bobbio at irq7.fr>
> # Date 1559641983 -7200
> #      Tue Jun 04 11:53:03 2019 +0200
> # Branch newdeb
> # Node ID 85a83e7be6610d301db86295120528bb1e074007
> # Parent  d5e1e2b627fcc78901cb5bbc15f049e86ba6b388
> Update Debian packaging

This looks good to me overall; this contains many nice improvements !

I pushed your patch in our review repository as a draft:

  https://hg.logilab.org/review/rql/rev/942ef0731f4c

I just fixed weird characters in hg user and debian/changelog entry.
Perhaps something is wrong in the machine you're sending patches from?

In order to test this (I use an sbuild machine plugged into our CI), we
need an update of logilab-database's packaging and respective binary
packages built. Did you start working on it? If so, I'll build this
first, then check this patch back and possibly apply.

Finally, we send all patches related to cubicweb ecosystem to
cubicweb-devel at lists.cubicweb.org (CCed) nowadays. The python-projects
mailing lists is kind of dead I think.

> diff -r d5e1e2b627fc -r 85a83e7be661 debian/control
> --- a/debian/control	Fri Feb 15 15:46:02 2019 +0100
> +++ b/debian/control	Tue Jun 04 11:53:03 2019 +0200
> @@ -5,18 +5,28 @@
>  Uploaders: Sylvain Thenault <sylvain.thenault at logilab.fr>, Nicolas Chauvat <nicolas.chauvat at logilab.fr>
>  Build-Depends:
>   debhelper (>= 9),
> - python-all-dev (>= 2.6.5),
> - python3-all-dev (>= 2.6.5),
> + dh-python,
> + python-all-dev,
> + python3-all-dev,
> + python-pytest,
> + python3-pytest,
> + python-unittest2,
> + python-logilab-common,
> + python3-logilab-common,
> + python-logilab-database,
> + python3-logilab-database,
>   libgecode-dev,
> - python-sphinx,
> + python3-sphinx,
>   python-setuptools,
>   python3-setuptools,
>   python-six,
> - python3-six,
> - dh-python,
> -X-Python-Version: >= 2.6
> -X-Python3-Version: >= 3.3
> -Standards-Version: 3.9.6
> + python3-six
> +X-Python-Version: >= 2.7
> +X-Python3-Version: >= 3.4
> +Standards-Version: 4.3.0
> +Testsuite: autopkgtest-pkg-python
> +Vcs-Hg: https://hg.logilab.org/master/yams
> +Vcs-Browser: https://hg.logilab.org/master/yams

Changed the lines above to rql.

>  Homepage: http://www.logilab.org/project/rql
>  
>  Package: python-rql
> @@ -26,7 +36,7 @@
>   ${misc:Depends},
>   ${shlibs:Depends},
>   python-logilab-common (>= 0.35.3-1),
> - yapps2-runtime,
> + python-yapps,
>   python-logilab-database (>= 1.6.0),
>   python-logilab-constraint,
>   python-six (>= 1.4.0),
> @@ -46,7 +56,7 @@
>   ${misc:Depends},
>   ${shlibs:Depends},
>   python3-logilab-common,
> - python3-yapps2-runtime,
> + python3-yapps,
>   python3-logilab-database (>= 1.6.0),
>   python3-logilab-constraint,
>   python3-six (>= 1.4.0),



More information about the cubicweb-devel mailing list